Start a new topic

SSL Handshaking problem...

So here's my connection log (edited to hide the URL and IP address, of course):  

Connecting to pr.....us
Connecting (AUTH TLS v1.0) to pr.....us:21 ...
Resolving url pr.....us to an IP address
Url resolved to IP address 52.1xx.1xx.133
Connecting to 52.1xx.1xx.133 on port 21
Connected successfully to the server on port 21
Logging on to server.
Logon to server was successful.
Testing directory listing ...
Connecting to 52.1xx.1xx.133 on port 63100
Connected successfully to the server on port 63100
 
Unable to connect to server, error information below
 
Error: SSL Handshaking failed (1705)
Operation: Connecting to server
Sub Operation: Performing secure handshake 

 I *can* connect to the exact same server using FileZilla, with the exact same credentials, so it's definitely not a server issue...


In FileZilla, however, I select "Require Explicit FTP over TLS" as the  Encryption Type.  There is no such selection in WebDrive.  But I have tried literally every different possibility in the FTP Settings | Security Type drop-down box, and this same SSL Handshake issue happens every time, no matter what that setting is.  I have enabled and disabled the various versions of SSL and TLS in the Connection Settings screen also, with no luck.  (Actually, if I enable SSL v2.0 it won't even get as far as the SSL Handshake -- it flat refuses to connect at all -- so I just leave that one off all the time.)

So I literally have no idea why it won't work.  It works in FileZilla.  Why not WebDrive?  What am I missing here?


Oh -- I'm using WebDrive 2017 (Build 4562) 64-bit on Windows Server 2012 R2, btw.


Thanks,

Laurence MacNeill

Ball Ground, Georgia, USA

1 Comment

Hi,


On the FTP Settings tab for your WebDrive Site Profile, make sure the Security Type is set to TLS Implicit and also make sure your Secure Data Channel setting is PROT P.



Login or Signup to post a comment
© 2016 South River Technologies®, Inc. - All Rights Reserved