Start a new topic

No "Allow NT Services to access mapped drive" setting available


we're considering your solution to become main SFTP connector for our customers but one of the requirements is that it must run as a service and start on boot so that other services can access the SFTP data. I've already found in the documentation such feature should be available. Yet the controls seem to be missing in the site configuration dialog.

What seems to be the problem?

Thank you for your response.


(18.4 KB)

Hello, I am having the same issue. I notice that this thread is 4 months old. Was there ever a solution? This is somewhat of a showstopper for me and if there's no fix then I'll be seeking a refund.

I am on v17.00 build 4562.




If the Allow NT Service Access option is not available in your Site Properties --> Advanced menu, then the logged in user is lacking the proper permissions or the install was not made using the Local Admin account.

To enable this setting, please Exit WebDrive using the system tray icon (right-click --> Exit WebDrive). Then, Run WebDrive as Administrator. Now go to Site Properties --> Advanced and enable the NT Service Access option. Then, Exit WebDrive using the system tray icon and then start WebDrive again normally (not as Admin). Then, connect the drive.

NOTE: You will not see the connection in the WebDrive UI, as it will no longer be accessible in this manner, as the WebDrive UI is not NT Service. The drive will be mapped and can be accessed by apps that are running in NT Service context (including the command prompt).

For more information on NT Service Access, please see the Help File in WebDrive under the Advanced section.

Hi, Thanks very much for the quick response. Much appreciated.

Running it as Administrator did indeed do the trick. I'm all up and running and am a happy user again!

Hopefully others with the same problem will now see this solution here.

Thanks again! :)

Login or Signup to post a comment
© 2016 South River Technologies®, Inc. - All Rights Reserved